Projects

From EditPlus Wiki
Jump to: navigation, search

This page could use some cleanup

When you load a Project, you are loading all related files together as a group.

First Time Users, first time through

  1. Open all the files you want to be grouped together. They can be different types, and can all be in different directories. Each file will have a tab visible at the bottom of the EditPlus window.
  2. In the main menubar, select Project --> Manage Project --> Add All to Project.
    You're done. The project named Default will now "remember" all the files you just added.
    You can open this whole group of files in "one step" at any time:Project --> Manage Project --> Load Project
  3. To review your project, select Project --> Manage Project --> Edit Project
    In the Projects pane, you will see the Default project. In the Files pane, you'll see the list of the files you just added. You can Add more files, select and move files around in the list using Up and Down, and Sort the list of files. After any changes, click Apply or OK.
  4. Click OK. Close each edit window with Ctrl-F4 or File --> Close. Quit EditPlus.
  5. Restart EditPlus. Select Project --> Manage Project --> Load Project. Voila!

Adding more Projects

  1. Select Project --> Manage Project --> Edit Project
  2. In the Projects pane, click Add. This creates an empty project called New Project
  3. Change the text "New Project" to a name you like
  4. In the Files pane, click Add...
    In the Select File window, you can select multiple files. Click OK.
    After that you can add/eliminate/modify/sort files in the project.
  5. Click Apply, or if done, click OK.


Navigation among the open files is done using

  • the bottom tabs,
  • the CTRL-TAB keyboard shortcut,
  • the left bottom icon folder
  • the Project item in the top tool bar.

All files pertaining to a project can be loaded and managed at once with 1 click! (well, ...)

1) go to Project --> Select Project (and DO SELECT the desired project)
2) go to Project --> Load Project (to actually load the project)

(... that were 6 clicks actually!)

At the end of editing session you can close all the files in the project with one click (rhetorical sense)

Project --> Manage Project ---> Close Project or
folder icon (at bottom left) ---> Manage Project ---> Close Project

If you are in a hurry and want a real 1 click quit, go to the red button in the upper task bar.

---

Note 1: For some users, in the beginning may be confused when he/she is attempting to load a project with only an empty default project. Nothing seems to happen.

  • The word default is just the name of a project. First Project | Manage Project | Edit, Add Files, Apply. Then Project | Manage Project | Load Project. If the files are already loaded, nothing will happen.


Note 2: Does it make a difference to use "Project" item in the tool bar or the little yellow folder icon at the bottom left corner the screen?

  • No. They offer the same options.